Read network info

Interface device access (V2.0)

Network info

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the network configuration settings. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access errorr
 | IPAddr | O | STRING | IP – Adsress
 | Subnet | O | STRING | Subnetmask
 | Gatewa | O | STRING | Gateway – Address
 | DNSAddr | O | STRING | DNS – Address
 | DHCPAct | O | STRING | DHCP – activation


Read systemstate

Systemstate

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the system state information. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | State1 | O | STRING | Statepart 1
 | State2 | O | STRING | Statepart 2
 | StrID | O | WORD | StringID
Parameter: | None
Remarks: | "State1" and "State2" together form a state string. A STRING - value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING –split values. Any additional strings will be truncated.


Read runstate

Runstate

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the run state information. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | Count | O | WORD | Number ofstates
 | State1 | O | STRING | Statepart 1
 | State2 | O | STRING | Statepart 2
 | BitSet | O | LONGLONG | Mask of states
Parameter: | The maximum number of readable states must be set using the function block (max 32/32 default).
Remarks: | "State1" and "State2" together form a state string. A STRING -value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING –split values. Any additional strings will be truncated.


Read error states

Errorstate

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the last error states. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | Count | O | WORD | Number ofstates
 | State1 | O | STRING | Statepart 1
 | State2 | O | STRING | State part 2
 | BitSet | O | LONGLONG | State mask
Parameter: | The maximum number of readable states must be set using the function block (max 32/32 default).
Remarks: | "State1" and "State2" together form a state string. A STRING - value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING – split values. Any additional strings will be truncated.


Read system state inf

System state info

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the actual system state information. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | User | O | WORD | Current percentage reserve for user applications
 | UserAva | O | WORD | average percent reserve for user applications
 | RT | O | WORD | Current percentage reserve for real time applications
 | RTAva | O | WORD | Average percentage reserve for real time applications
 | RTOver | O | WORD | Number of real time errors
Parameter: | none
Remarks: | none


Read systeminformation

Systeminformation

Symbol: |
Description: | If at the input "GetValu" a HIGH - signal is present, the function block reads the system description information. An error during read at the output" Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | Name1 | O | STRING | System name part 1
 | Name2 | O | STRING | System name part 2
 | DType | O | STRING | Device name
 | DTypeC | O | STRING | Device type code
 | MMType | O | WORD | Main module type
 | SMType | O | WORD | Sub module type
 | FMType | O | WORD | Functiontype
 | CMType | O | WORD | Housing type
 | SerialNo | O | STRING | Serial number
 | Firmware | O | STRING | Firmware version
 | IsBigEnd | O | BIT | Byte - alignment
 | MeaRate | O | DOUBLE | Measurement rate
 | IPRate | O | DOUBLE | Internal processing rate
 | DBCount | O | WORD | Number of data buffer
 | LogCount | O | WORD | Number of loggers
 | VarCount | O | WORD | Number of variables
 | ModCount | O | WORD | Number of modules
Parameter: | none
Remarks: | "Name1" and "Name2" together form a state string. A STRING - value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING –split values. Any additional strings will be truncated.


Read list of device variables

List ofvariables

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the list of system variables. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | Name1 | O | STRING | Name of variablepart 1
 | Name2 | O | STRING | Name of variable part 2
 | VType | O | STRING | Type
 | StrForm | O | STRING | String of format
 | Unit | O | STRING | Unit
 | DType | O | STRING | Data type
 | DTypeC | O | UCHAR | Data type code
 | IODirec | O | UCHAR | direction
 | IOffset | O | WORD | Input Offset
 | OOffset | O | WORD | Output Offset
Parameter: | The maximum number of readable states must be set using the function block (Max. 1024 / Default 128).
Remarks: | "Name1" and "Name2" together form a state string. A STRING - value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING –split values. Any additional strings will be truncated.


Read minformation of modules

Module information

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the list of module description information. An error during read at the output" Error" is displayed. .
Signals: | Name | I/O | Type(s) | Function
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | Name1 | O | STRING | Name of module part 1
 | Name2 | O | STRING | Name of module part2
 | DType | O | STRING | Type of module
 | DTypeC | O | STRING | Type code of module
 | MMType | O | WORD | Main module type
 | SMType | O | WORD | Sub module typep
 | FMType | O | WORD | Functiontype
 | CMType | O | WORD | Housing type
 | UARTIdx | O | STRING | UART –index
 | UARTAddr | O | STRING | UART address
 | NumVars | O | WORD | Number of module variables
Parameter: | The maximum number of readable states must be set using the function block (Max. 128 / Default 16).
Remarks: | "Name1" and "Name2" together form a state string. A STRING - value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING – split values. Any additional strings will be truncated.


Read list of module variables

Liste of module variables

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block reads the list of module variables information. An error during read at the output "Error" is displayed.
Signals: | Name | I/O | Type(s) | Function
 | Modul | I | WORD | Modul - Index
 | GetValu | I | BIT | Activate reading
 | Error | O | WORD | Access error
 | Name1 | O | STRING | Name of variable part 1
 | Name2 | O | STRING | Name of variable part 2
 | VType | O | STRING | Type
 | StrForm | O | STRING | String of format
 | Unit | O | STRING | Unit
 | DType | O | STRING | Data type
 | DTypeC | O | UCHAR | Data type code
 | IODirec | O | UCHAR | direction
 | IOffset | O | WORD | Input Offset
 | OOffset | O | WORD | Output Offset
Parameter: | The maximum number of readable states must be set using the function block (Max. 128 / Default 24).
Remarks: | "Name1" and "Name2" together form a state string. A STRING - value represents a maximum of 17 characters. For this reason, longer strings will be a maximum of 2 STRING – split values. Any additional strings will be truncated.


Read value of variable

Read value

Symbol: |
Description: | When calling the functionblock, the variable value is read at the offset specified and deployed to the output that corresponds to the specified data type code. For further processing, the index of the output is indicated by the current value at output "ValIdx". A ValIdx –1 indicates that no output could be assigned. ValIdx = 0 indicates a bit value, ValIdx = 1 indicates a byte value etc.
Signals: | Name | I/O | Type(s) | Function
 | DTypeC | I | UCHAR | Data type code
 | IOffset | I | WORD | Output Offset
 | BitVal | O | BIT | Bit – value
 | ByteVal | O | UCHAR | Byte - valuet
 | WVal | O | WORD | Word –value
 | LVal | O | LONG | Long –value
 | LLVal | O | LONGLONG | Long Int –value
 | FVal | O | FLOAT | Float –value
 | DVal | O | DOUBLE | Double –value
 | ValIdx | O | WORD | Corresponding output
Parameter: | none
Remarks: | This function block is intended for us a connection with the use of list elements of the function blocks " list of module variables" or " List of System Variables ".


Write value of variable

Write value

Symbol: |
Description: | If at the input "GetValu" a HIGH-signal is present, the function block writes the value to the specified offset. An error during read at the output "Error" is displayed. The value is used which is connected to the input which corresponds to the predetermined data type code.
Signals: | Name | I/O | Type(s) | Function
 | DTypeC | I | UCHAR | Data type code
 | IOffset | I | WORD | Output Offset
 | BitVal | I | BIT | Bit - value
 | ByteVal | I | UCHAR | Byte - value
 | WVal | I | WORD | Word - value
 | LVal | I | LONG | Long - value
 | LLVal | I | LONGLONG | Long Int - value
 | FVal | I | FLOAT | Float - value
 | DVal | I | DOUBLE | Double - value
 | SetValu | O | BIT | Activate writing
Parameter: | keine
Remarks: | This function block is intended for use in connection with the use of list elements of the function blocks " list of module variables" or " List of System Variables ".


Write network information

Write network info

Symbol: |
Description: | If at the input "SetValu" a HIGH-signal is present, the function block writes the configured network info into the system. An error during read at the output "Error" is displayed.
Signals: | Name |  | I/O | Type(s) | Function
 | DevName |  | I | STRING | Device name
 | IPAddr |  | I | STRING | IP - address
 | Subnet |  | I | STRING | Subnetmask
 | Gateway |  | I | STRING | Gateway – address
 | DNSAddr |  | I | STRING | DNS – address
 | DHCPAct |  | I | STRING | DHCP – activation
 | Activat |  | I | BIT | Activate the updated information
 | Save |  | I | BIT | Save the updated version in the appropriate configuration files
 | SetValu |  | I | BIT | Activate write
 | Error |  | O | WORD | Access error
Remarks: |  | None


Calling system defined functions

Generic function call

Symbol:

Description:

If at the input "CallFc" a HIGH-signal is present and no other block of this type is active, the function block calls at the function defined by name at the input "StrFcnt". With each subsequent call of the block it is checked that function call has been processed or has reached its timeout. Errors occur during processing are shown at the corresponding outputs.

Signals:

Name

I/O

Typ(s)

Function

StrFcnt

I

STRING

Name of function

Timeout

I

LONG

Timeout

IStr

I

STRING

Input String vector

IInt64

I

LONGLONG

Input INT64 vector

IDouble

I

DOUBLE

Input Double vector

CallFc

I

BIT

Activate call

FBError

O

WORD

Error code function block

FCError

O

WORD

Return code of function

State

O

WORD

State

OStr

O

STRING

Output String vector

OInt64

O

LONGLONG

Output INT64 vector

ODouble

O

DOUBLE

Output Double vector

Parameter:

The maximum number of detectable return values must be set using the function block.

Remarks:

System – defined functions can be accessed with this function module. If several blocks are used, only one block receives the execution token. Only when this block is finished or its timeout has expired, the next block of this type receives the token. All other blocks are processed in the normal time-defined context.

The block holds the "READY" state until it is reactivated. This status is also set if an error occurred during processing.


Error codes

Value | Description
0 | No error
-1 | At the "Device Access" interface connection could not be established
-2 | Failed to run method
-3 | The list of modules is not available
-4 | The module is not available
-5 | The list of variables is not available
-6 | Too much variables available. The number of provided buffers can be changed in the parameter dialog
-7 | Too much modules available. The number of provided buffers can be changed in the parameter dialog
-8 | The device information is not available
-9 | The information to the device variables are not available.
-10 | The error states are not available
-11 | The run state is not available
-12 | Too much states available. The number of provided buffers can be changed in the parameter dialog
-13 | The „Health“ – Information are not available


State codes

Value | Description
0 | No activity
1 | Call is active
2 | Call wasactivated
3 | Interface is busy (BUSY)
4 | Call was terminated (READY)