Up-down-counter

Symbol: |
Description: | This function block counts positive going edges in the inputs vz and rz (one edge per loop). If the input c is set to HIGH, the counter output is reset to 0. When the counter over- or underflows the carry output is set for one program cycle.
Signals: | Name | I/O | Type(s) | Function
 | vz | I | BIT | Up counting input
 | rz | I | BIT | Down counting input
 | c | I | BIT | Reset
 | iz | O | WORD | Counter
 | ue | O | BIT | Carry signal
Comment: | This function block is used to count slow binary events (the pulse interval must be longer than the program cycle).