Off-delay

Symbol: |
Description: | This timer function block realizes an off-delay timing. If the input iN changes from TRUE to FALSE, switching off the output Q is delayed for the time interval at input PT. After the delay time PT has passed, the output Q is set to FALSE. The remaining time of the delay is provided at the output ET.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | iN | I | BIT | Input signal
 | PT | I | TIME | Preset time interval for the delay
 | Q | O | BIT | Output signal
 | ET | O | TIME | Remaining time of the delay
Visualization: | If the output Q is set to TRUE, the function block will be highlighted


On-delay

Symbol: |
Description: | This timer function block realizes an on-delay timing. If the input iN changes from FALSE to TRUE, switching on the output Q is delayed for the time interval at input PT. After the delay time PT has passed, the output Q is set to TRUE. The remaining time of the delay is provided at the output ET.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | iN | I | BIT | Input signal
 | PT | I | TIME | Preset time interval for the delay
 | Q | O | BIT | Output signal
 | ET | O | TIME | Remaining time of the delay
Visualization: | If the output Q is set to TRUE, the function block will be highlighted.


Pulse

Symbol: |
Description: | This timer function block creates a pulse. If the input iN changes from FALSE to TRUE, a pulse is created at output Q for the time interval provided at input PT. The remaining time of the pulse is provided at the output ET. If iN gets TRUE for another time and PT has not been elapsed, it has no impact on the duration of the pulse created at output Q.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | iN | I | BIT | Input signal
 | PT | I | TIME | Preset time interval for the pulse
 | Q | O | BIT | Output signal
 | ET | O | TIME | Remaining time of the pulse
Visualization: | If the output Q is set to TRUE, the function block will be highlighted


Real time clock

Symbol:

Description:

This function block creates a real time clock and provides ist time and date at the output CDT. As long as the input EN is TRUE the clock is running. Otherwise the clock is on hold, but still provides its last time stamp.

If the input DT is connected, the value provided at this input is taken as the starting point of the clock, when the input EN changes from FALSE to TRUE.

If the input DT is not connected, the current system time will be taken as the starting point of the clock, when the input EN changes from FALSE to TRUE.

The output Q displays the state of input EN.

Parameter:

The parameter dialog can be used to define whether or not the current time and date will be shown in the symbol during the run mode. The format of the display can be chosen, too.

Signals:

Name

I/O

Type(s)

Function

EN

I

BIT

Input signal

DT

I

DT

Preset date and time

Q

O

BIT

Output signal

CDT

O

DT

Actual date and time

Visualization:

The color of the icon from the input EN indicates whether or not the clock is currently running.

Furthermore the function block can directly depict its actual time and date in two different formats: