Addition (Date & Time)

Symbol:

Description:

This function block adds a duration to a time value of data type Date&Time. The output value is a time value of the type Date&Time.

The operation exceeds the domain of the date (1-1-1970 to 1-18-2038) is reset the value on 1-1-1970 00:00:00.

Signals:

Name

I/O

Type(s)

Function

IN1

I

DT

Date & time

IN2

I

TIME

Duration

OUT

O

DT

Calculated value date & time


Addition (Duration)

Symbol:

Description:

This function block adds two time durations. The output value is the calculated duration of the type Time.

If the operation exceeds the limits of the duration data type (49 days 17 hours 2 min 47 sec and 295 ms) the value is starting at 0.

Signals:

Name

I/O

Type(s)

Function

IN1

I

TIME

Duration 1

IN2

I

TIME

Duration 3

OUT

O

TIME

Calculated duration.


Addition of duration to time

Symbol:

Description:

This function block adds a duration to a time of day. The output value is a time value of the data type Time Of Day.

If the operation exceeds the value 23:59:59 hours the calculation is continued with 00:00:00 hours.

Signals:

Name

I/O

Type(s)

Function

IN1

I

TOD

Time of day

IN2

I

TIME

Duration

OUT

O

TOD

Calculated time of day


Division (Duration)

Symbol: |
Description: | This function block divides a time duration by a WORD value.
Signals: | Name | I/O | Type(s) | Function
 | IN1 | I | TIME | Duration
 | IN2 | I | WORD | Divisor
 | OUT | O | TIME | Calculated duration


Link date and time to date & time

Symbol: |
Description: | This function block concatenates a date and a time of day together to time value of the data type Date&Time.
Signals: | Name | I/O | Type(s) | Function
 | IN1 | I | DATE | Date
 | IN2 | I | TOD | Time of day
 | OUT | O | DT | Date & time


Multiplication (Duration)

Symbol: |
Description: | This function block multiplies a time duration with a WORD value. If the operation exceeds the limits of the duration data type (49 d 17 h 2 min 47 sec und 295 ms) the operation is continued at the value 0 ms.
Signals: | Name | I/O | Type(s) | Function
 | IN1 | I | TIME | Duration
 | IN2 | I | WORD | Multiplier
 | OUT | O | TIME | Calculated duration


Subtraction (Date)

Symbol: |
Description: | This function block subtracts a date from another date. The output value is a duration of the data type TIME. If the input value IN2 is greater than the input value IN1, the output is always 0.
Signals: | Name | I/O | Type(s) | Function
 | IN1 | I | DATE | Date 1
 | IN2 | I | DATE | Date 2
 | OUT | O | TIME | Calculated duration


Subtraction (Date & Time)

Symbol:

Description:

This function block subtracts a time value of data type Date&Time from another value of the same type. The output value is a time duration of the date type TIME.

If the input value IN2 is greater than the input value IN1, the output is always 0. This is also the case if the result would exceed the maximum of a TIME duration (49 d 17 h 2 min 47 sec und 295 ms).

Signals:

Name

I/O

Type(s)

Function

IN1

I

DT

Date & time 1

IN2

I

DT

Date & time 2

OUT

O

TIME

Calculated duration


Subtraction (Duration)

Symbol: |
Description: | This function block subtracts a time duration from another one. The output value is the calculated duration of the type Time. The result is always the positive difference between the two input values.
Signals: | Name | I/O | Type(s) | Function
 | IN1 | I | TIME | Duration 1
 | IN2 | I | TIME | Duration 2
 | OUT | O | TIME | Calculated duration


Subtraction of duration from date & time

Symbol:

Description:

This function block subtracts a duration from a time value of the data type Date&Time. The output value is a time value of the type Date&Time.

If the difference is below the limit of the time value Date&Time (1-1-1970 00:00:00) the value 1-1-1970 00:00:00 is given back as output value.

Signals:

Name

I/O

Type(s)

Function

IN1

I

DT

Date & time

IN2

I

TIME

Duration

OUT

O

DT

Calculated value date & time


Subtraction duration from time

Arithmetic (Time)

Subtraction of duration from time

Symbol:

Description:

This function block subtracts a duration from a time value of the data type time of day. The output is a time value of the data type time of day.

If the operation falls below the value 00:00:00 hours the calculation is continued with 23:59:59 hours.

Signals:

Name

I/O

Type(s)

Function

IN1

I

TOD

Time of day

IN2

I

TIME

Duration

OUT

O

TOD

Calculated time of day


Subtraction (Time)

Symbol: |
Description: | This function block subtracts a time of day from another value if the same data type. The output value is the calculated duration of the type Time. The result is always the positive difference between the two input values.
Signals: | Name | I/O | Type(s) | Function
 | IN1 | I | TOD | Time of day 1
 | IN2 | I | TOD | Time of day 2
 | OUT | O | TIME | Calculated duration