Select Active Screen

Symbol:

Description:

This function block can switch the view to another virtual screen.

Every runtime kernel creates its display representation into its own frame buffer. If a system runs multiple kernels, only one has the right to display its frame buffer to the real screen. Any input device (mouse, touch) will be directed to the runtime environment, which currently holds the right to access the display. Every kernel manages its input separately. In this way, it is ensured that any input done before a screen switch will not influence anything after the change. Only the kernel which currently can use the display has the exclusive right to hand this access over to another kernel. This will be this function block.

By using the input Screen a number of another kernel or frame buffer can be given (starting with 1). If the input Switch changes to HIGH, the right to access the display changes to the given kernel. This access right can only be given away. To be able to switch back,it is necessary to use this function block also in the application of the alternative runtime environment as well.

Signals:

Name

I/O

Type(s)

Function

Screen

I

WORD

Number of the frame buffer

Switch

I

BIT

Switch

Comment:

After the switch of the display the frame buffer currently not showing will still be updated by the running application.


Read Actual Runtime

Symbol:

Description:

This function block is used to perform a runtime measurement within an application. It will determine the elapsed time since thestarting function blockor the previous measurement function block respectively. That means this function block has to be placed behind a starting block in the working sequence.

The input Freeze is used to halt the measurement. The value at the output D2First shows the elapsed time since the starting block and the output D2Bev shows the elapsed time since the previous measurement function block. These values show the run time in nanoseconds (ns). The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

Freeze

I

BIT

Halt measurement

D2First

O

LONG

Elapsed run time since stating block in [ns]

D2Bev

O

LONG

Elapsed run time since previous measurement block in [ns]

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-2 | Maximum number of surveillance points is exceeded.
-3 | The measuring point is invalid.
-4 | No starting point found.
-110 | Access failure by the driver.


Set Backlight

Symbol:

Description:

This function block is used to modify the backlight setting of the display. This can change the brightness of the screen toward a darker or lighter display.

A brightness value in percent can be assigned to the SetVal input. The output ActVal will show the currently set value. The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

SetVal

I

WORD

Brightness value to set in [%]

ActVal

O

WORD

Actual brightness value in [%]

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-1 | The board could not be accessed.
-2 | The current brightness value couldn't be read.
-3 | The brightness value couldn't be set.


Read BIOS Info (Long)

Symbol:

Description:

This function block can read numerical values out of the BIOSinformation.

The input InfoNo is used to give the index of the desired information. The read value is given at the output UlInfo. The following table shows the possible information:

Index | Information
0 | Boot counter
1 | Counter of operation hours

The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

InfoNo

I

WORD

Index of the wanted BIOS information

UlInfo

O

LONG

Read value

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-1 | The board could not be accessed.
-4 | The BIOS information could not be read.
-5 | The index is invalid.


Read BIOS Info (String)

Symbol:

Description:

This function block can read alphanumerical values out of the BIOS information.

The input InfoNo is used to give the index of the desired information. The read value is given at the output StrInfo. The following table shows the possible information:

Index | Information
0 | Board ID
1 | Serial number
2 | Product revision
3 | BIOS Version
4 | Date and time of the board production
5 | Date and time of the last maintenance

The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

InfoNo

I

WORD

Index of the wanted BIOS information

StrInfo

O

TEXT

Read text

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-1 | The board could not be accessed.
-4 | The BIOS information could not be read.
-5 | The index is invalid.


BIOS-Time to System

Symbol:

Description:

This function block can be used to synchronize the system time with the BIOS time.

If the input bSync is HIGH, the system time will be set to the value of the current BIOS time.

This can be utilize to keep the system time to a more precise value, if the system time is set regularly to the value of the hardware clock.

Signals:

Name

I/O

Type(s)

Function

vSync

I

BIT

Switch

Comment:

This function block is useful in combination with the real time clock (RTC) function block.


Read Board – Temperatures

Symbol:

Description:

This function block can be used to read temperatures from the Q7 board.

The index to specify the temperature sensor is given by the input Sensor. The output Tempera will show the read temperature value of the selected sensor. If the value is 0, the sensor is not connected. The following table shows the possible information:

Index | Information
1 | CPU temperature
2 | Board temperature
3 | System temperature
4 | Memorytemperature
5 | Chipset temperature
6 | Videochip temperature

The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

Sensor

I

WORD

Index of the temperature sensors

Tempera

O

LONG

Temperature value

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-1 | The board could not be accessed.
-6 | The index is invalid.


CPU – Load

Symbol:

Description:

This function block will measure the CPU load of the user space.

If the input Activat is HIGH the measurement will start. The output CPULoad will show the current working load of the user applications in percent. The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

Activat

I

BIT

Starting the measurement

CPULoad

O

FLOAT

CPU loadin [%]

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-100 | State file can't be opened.
-101 | State file can't be read.
-102 | State line can't be read.


Read Realtime Errors

Symbol:

Description:

This function block can be used to read the number of realtime errors within a specified module since the start of the application.

A realtime error occurs, if at the start of a new realtime cycle the module could not end all of its operations yet.

The input Module is used to specify the module. A value of 0 up to 8 is valid. The output Counter shows the number of realtime errors. The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

Module

I

WORD

Number of the module

Counter

O

LONG

Number of realtime errors in the selected module

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-1 | The necessary data structure for diagnosis information couldn't be initialized.
-300 | The input value is invalid.


Start Runtime-Measurement

Symbol:

Description:

This function block forms the starting point of a runtime measurement within an application.

It creates a time stamp which is the reference point for the measurement function block. This function block is essential for a runtime measurement. Only one starting function block is meaningful within an application.

The input Freeze is used to stop the measurement. In this case no time stamp for the starting point will be created. The output Err will show an error number.

Signals:

Name

I/O

Type(s)

Function

Freeze

I

BIT

Stop measurement

Err

O

WORD

Error indicator

Comment:

Error number:
0 | No error
-2 | Maximum number of surveillance points is exceeded.
-110 | Access failure by the driver.


Time of System to BIOS-Time

Symbol: |
Description: | This function block is used to synchronize the BIOS time with the value of the system time. If the input bSync is HIGH, the BIOS time will be set to the current value of the system time. In this way the hardware clock can be set by an application.
Signals: | Name | I/O | Type(s) | Function
 | vSync | I | BIT | Switch
Comment: | This function block is useful in combination with the real time clock (RTC) function block. Attention: It has to mind, that changing the BIOS time to an earlier date is not recommended. This can lead to conflicts with existing files and their timestamps in the file system, because it is now a point of time in the future.


Input Monitoring

Symbol:

Description:

This function is used to monitor the input of an application by mouse or touch screen. It recognizes if a certain period of time has passed without such inputs.

The period of time can be specified by the input TimeSec in seconds. If there is no user input within this time frame, the output expired will be set to HIGH. If such a user input happens, the internal time measurement will reset and the monitoring period starts again.

Signals:

Name

I/O

Type(s)

Function

TimeSec

I

WORD

Period of timein [s]

expired

O

BIT

Indicates no user input


Interface to a selected managed application

Symbol: |
Description: | The information about the running applications are centrally managed to provide the information of a selected application (in the standard case, the initial application - Q.App). This function block allows to get information for a specified user application. Please be careful by using the Switch input. (have a look at “ Select active screen ”)
Signals: | Name | I/O | Typ(s) | Function
 | ApName | O | TEXT | Name of application
 | ApInfo | O | TEXT | Info over application
 | ApType | O | TEXT | Type of application
 | ApAdd1 | O | TEXT | Additional info
 | ApAdd2 | O | TEXT | Additional info
 | ApAdd3 | O | TEXT | Additional info
 | HMIAct | O | BIT | HMI flag
 | ApAct | O | BIT | Activity flag
 | Screen | O | WORD | Number of Framebuffer
 | bError | O | BIT | Error flag
 | ApIdx | I | WORD | Index of managed applications
 | Switch | I | BIT | Switch to initial application
Remarks: | The error flag indicates whether the entry of the information couldn’t be read. An example of using this function block is the standard initial application (Q.app). Here are displayed the information of the second user application.


Interface to all managed applications

Tools & Diagnosis (V2.0)

Interface to all managed userapplications

Symbol:

Description:

The information about the running applications are centrally managed to provide the information of a selected application (in the standard case, the initial application - Q.App).

This function block allows to get information for all managed applications. All information are provided as vectors. Because the acquisition of information takes some time this will only done when the input GetInfo is high.

To switch to another screen the function block “ Select active screen ” has to be used.

Signals:

Name

I/O

Typ(s)

Function

ApName

O

TEXT

Name of application

ApInfo

O

TEXT

Info over application

ApType

O

TEXT

Type of application

ApAdd1

O

TEXT

Additional info

ApAdd2

O

TEXT

Additional info

ApAdd3

O

TEXT

Additional info

HMIAct

O

BIT

HMI flag

ApAct

O

BIT

Activity flag

Screen

O

WORD

Number of Framebuffer

bError

O

BIT

Error flag

GetInfo

I

BIT

Activate getting information

Remarks:

The error flag indicates whether the entry of the information couldn’t be read.


Interface to initial application

Symbol:

Description:

The information about the running applications are centrally managed to provide the information of a selected application (in the standard case, the initial application - Q.App).

This function block allows to enter information in this administration. The name, info and activity flag be evaluated in the basic version of the initial application (as the default real-time application information is not included in the display).

If the HMIAct input is high this informs the initial application that a HMI screen within the user application is available. In this case the user application has to provide a display control element to switch back to the initial application. (have a look at “ Select active screen ”)

Signals:

Name

I/O

Typ(s)

Function

ApName

I

TEXT

Name of application

ApInfo

I

TEXT

Info over application

ApAdd1

I

TEXT

Additional info

ApAdd2

I

TEXT

Additional info

ApAdd3

I

TEXT

Additional info

HMIAct

I

BIT

HMI flag

ApAct

I

BIT

Activity flag

bError

O

BIT

Error flag

Switch

I

BIT

Switch to initial application

Remarks:

The error flag indicates whether the entry of the information was successful.

For example, an individualized initial application can use the additional information to display selected values.