Append

Symbol: |
Description: | This function block will append the text from input Te2 to the text from input Te1 and create a new combined text at the output.
Signals: | Name | I/O | Type(s) | Function
 | Te1 | I | TEXT | Text 1
 | Te2 | I | TEXT | Text 2
 | TeA | O | TEXT | Text output


Comparator

Symbol:

Description:

This function block compares the two strings connected to Te1 and Te2 (including spaces).

Bits 0..3 of the status byte reflect the result of this comparison (see below). Bits 4..7 are unaffected.

The comparison for < or > doesn’t correspond to the text length, but to the ASCII value of the first distinctive character.

Status byte:

Bit 0 = 1 Te1 = Te2

Bit 1 = 1 Te1 != Te2

Bit 2 = 1 Te1 > Te2

Bit 3 = 1 Te1 < Te2

Signals:

Name

I/O

Type(s)

Function

Te1

I

TEXT

Text 1

Te2

I

TEXT

Text 2

SB

O

BYTE

Status byte


Multiplexer

Symbol: |
Description: | This function block puts the element N from input vector vT to the output Ta. If N is beyond the limit of the vector vT, the last element will be connected to the output.
Signals: | Name | I/O | Type(s) | Function
 | vT | I | TEXT | Text vector
 | N | I | WORD | Index to access the vector
 | Ta | O | TEXT | Text output


Switch

Symbol:

Description:

This function block selects a text from one of two sources depending on the state of the binary input P.

If P is LOW the text from Te0 will be connected to the output, otherwise the text Te1 will be connected to the output TeA.

Operation:

P = LOW TeA = Te0

P = HIGH TeA = Te1

Signals:

Name

I/O

Type(s)

Function

Te0

I

TEXT

Text 1

Te1

I

TEXT

Text 2

P

I

BIT

Switch

TeA

O

TEXT

Text output

Visualization:

The state of the switch is shown in the symbol.