Interface to initial application

Symbol:

Description:

The information about the running applications are centrally managed to provide the information of a selected application(in the standard case, the initial application-Q.App).

This function block allows to enter information in this administration. The name, info and activity flag be evaluated in the basic version of the initial application(as the default real-time application information is not included in the display).

Signals:

Name

I/O

Typ(s)

Function

ApName

I

TEXT

Name of application

ApInfo

I

TEXT

Info over application

ApAdd1

I

TEXT

Additional info

ApAdd2

I

TEXT

Additional info

ApAdd3

I

TEXT

Additional info

ApAct

I

BIT

Activity flag

bError

O

BIT

Error flag

Remarks:

The error flag indicates whether the entry of the information was successful.

For example,an individualized initial application can use the additional information to display selected values.