Derivative term

Symbol: |
Description: | This function block realizes a derivative term. The output is the derivative function of the input signal X.
Operation: | Das derivative term realizes the following function: Step response:
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Input signal
 | Y | O | FLOAT | Output signal
Comment: | This function block is a basic term whenever a derivation is needed (Y=dX).


DT1-Term

Symbol: |
Description: | This function block realizes a first-order lag derivative term.
Operation: | Das DT1-Term realizes the following function: Step response:
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Input signal
 | T1 | I | FLOAT | Tine constant in [s]
 | Y | O | FLOAT | Output signal
Comment: | This function block is a basic term whenever a first order lag derivative is needed.


Integral term

Symbol:

Description:

The output Y reflects the integral value of the input X over the time.

Input Ti selects the time constant. A logical 1 at the preset input Pr causes the integrator to assume the preset value PrW.

The trapezoid rule is used to compute the integral. Integration constant K is only computed at program start, or whenever Ti changes:

Operation:

The integral term realizes the following function:

Step response:

Signals:

Name

I/O

Type(s)

Function

X

I

FLOAT

Input signal

Ti

I

FLOAT

Time constant in [s]

Pr

I

BIT

Preset

PrW

I

FLOAT

Preset value

Y

O

FLOAT

Output signal

Comment:

This function block is a basic term to create structures.


Nonlinearity

Symbol:

Description:

This function block is used for curve linearization.

With the use of the designated sample nodes an output value Y will be calculated for any applied input Value X. The reference points are given with the two connected vectors NodeX and NodeY. Elements in these vectors with the same index define the pairs of values for the reference nodes.

The two vectors must contain the same amount of elements. All values in the vector NodeX have to be strictly increasing. The first none rising value will be taken as the end of the characteristic curve. Any more pairs of value will be ignored.

If the value X is outside the X-axis of the reference points the calculation will be done by virtually increase the outer left or right part of the characteristic curve beyond the first or last significant point.

There are at least two reference nodes needed to be able to make a useful calculation.

Signals:

Name

I/O

Type(s)

Function

NodeX

I

FLOAT

X-vector for reference points

NodeY

I

FLOAT

Y-vector for reference points

X

I

FLOAT

Input signal

Y

O

FLOAT

Output signal

Visualization:

If the connected vectors don’t have the same length, the symbol will be depicted red in run mode.

Comment:

This function block may be used for correction of lines for non linear sensors or the realization of non linear controllers.


Proportional term

Symbol: |
Description: | This function block realizes a multiplication between float values.
Operation: | The proportional term realizes the following function: Step response:
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Input signal
 | K | I | FLOAT | Transmission constant
 | Y | O | FLOAT | Output signal


PT1-Term

Symbol: |
Description: | This function block implements a first-order filter using the difference equation.
Operation: | The PT1-term realizes the following function: The coefficient K will be calculated only at the program start or if T1 is changed. Step response:
Signals: | Name | I/O | Type(s) | Function
 | Xe | I | FLOAT | Input signal
 | T1 | I | FLOAT | Time constant in [s]
 | Xa | O | FLOAT | Output signal
Comment: | The function block may be used in analogue measurement filtering applications, or as part of a dynamic system simulation..


PT2-Term

Standard transmission terms (Float)

PT2-Term (able to oscillate)

Symbol: |
Description: | This function block realizes a second-order lag proportional transitions term that is able to oscillate. The output oscillates if the attenuation is in the range of 0 < A < 1.
Operation: | The PT2-term realizes the following function: Step response (variable attenuation, A:D, TC:T): Step response (variable time constant, A:D, TC:T):
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Input signal
 | TC | I | FLOAT | Time constant in [s]
 | A | I | FLOAT | Attenuation
 | Y | O | FLOAT | Output signal
Comment: | This function block will be used typically for simulation of dynamic processes.