Absolute value

Symbol: |
Description: | This function block computes the absolute value of its input value X. The result will be presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand
 | Y | O | FLOAT | Result


Arc tangent

Symbol: |
Description: | This function block computes the mathematical arc tangent of its input signal X, given in radians. The result will be presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand in radians
 | Y | O | FLOAT | Result


Cosine

Symbol: |
Description: | This function block computes the mathematical cosine of its input signal X, given in radians. The result will be presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand in radians
 | Y | O | FLOAT | Result


Exponential function

Symbol: |
Description: | This function block computes exponential function, i.e. the result Y is Euler's number e raised to the power of the value X. The result is presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Exponent
 | Y | O | FLOAT | Result


Logarithm to the base of 10

Symbol: |
Description: | This function block computes the common logarithm to the base 10 from the absolute value of the input signal X. The result is presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand
 | Y | O | FLOAT | Result
Comment: | The function sets the output Y to -3.4E38 when the value X is zero.


Natural Logarithm

Symbol: |
Description: | This function block computes the natural logarithm, i.e. the logarithm to the base e (Euler's number), from the absolute value of the input signal. The result is presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand
 | Y | O | FLOAT | Result
Comment: | The function sets the output Y to -3.4E38 when the value X is zero.


Power function

Symbol: |
Description: | This function block computes the exponentiation with the base X1 and the exponent X2, i.e. X1 raised to the power of X2. The result is presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X1 | I | FLOAT | Base
 | X2 | I | FLOAT | Exponent
 | Y | O | FLOAT | Result


Sine

Symbol: |
Description: | This function block computes the mathematical sine of its input signal X, given in radians. The result will be presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand in radians
 | Y | O | FLOAT | Result


Sign assignment

Symbol: |
Description: | This function block can be used to assign different signs to the input value X according to the value at the input I. IF I>=0.0, then the value X is multiplied with 1.0, otherwise X is multiplied with -1.0.
Operation: | Y = X * 1.0 or Y = X * -1.0
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Input value
 | I | I | FLOAT | Indicator for the sign
 | Y | O | FLOAT | Output value
Comment: | This function block can be used to detect the sign of a changeable value and so work like a sign function. If the input X has a fixed value and the changeable signal is connected to I, the output Y will alternate between +X and –X.


Square Root

Symbol:

Description:

This function block computes the square root of its input value X. The result is presented at the output Y.

The square root is taken from the absolute value of X and any sign is applied after that operation.

Operation:

Signals:

Name

I/O

Type(s)

Function

X

I

FLOAT

Operand

Y

O

FLOAT

Result


Tangent

Symbol: |
Description: | This function block computes the mathematical tangent of its input signal X, given in radians. The result will be presented at the output Y.
Operation: |
Signals: | Name | I/O | Type(s) | Function
 | X | I | FLOAT | Operand in radians
 | Y | O | FLOAT | Result