Pulse width modulated signal

Symbol:

Description: | This function block generates a rectangle signal with the specified pulse width (ms), frequency (Hz) and amplitude.

Signals: | Name | I/O | Type(s) | Function
 | Freq | I | FLOAT | Frequency
 | Ampl | I | FLOAT | Amplitude
 | PulseW | I | FLOAT | Pulse width in [ms]
 | Out | O | FLOAT | Signal
Comments: | The quality of the signal is dependent of: - the minimal cycle time of the target system - the adjusted cycle time and - the adjusted frequency (see also signal qualities).


Rectangle signal

Symbol:

Description: | This function block generates a rectangle wave signal with the specified frequency (Hz), the amplitude and pulse width (in percent).

Signals: | Name | I/O | Type(s) | Function
 | Freq | I | FLOAT | Frequency
 | Ampl | I | FLOAT | Amplitude
 | PulseW | I | FLOAT | Pulse width in [%]
 | Out | O | FLOAT | Signal
Comments: | The quality of the signal is dependent of: - the minimal cycle time of the target system - the adjusted cycle time and - the adjusted frequency (see also signal qualities).


Sawtooth signal

Symbol:

Description: | This function block generates a sawtooth wave signal with the specified frequency (Hz) and amplitude.

Signals: | Name | I/O | Type(s) | Function
 | Freq | I | FLOAT | Frequency
 | Ampl | I | FLOAT | Amplitude
 | Out | O | FLOAT | Signal
Comments: | The quality of the signal is dependent of: - the minimal cycle time of the target system - the adjusted cycle time and - the adjusted frequency (see also signal qualities).


Sine signal

Symbol:

Description: | This function block generates a sine wave signal with the specified frequency (Hz) and amplitude.

Signals: | Name | I/O | Type(s) | Function
 | Freq | I | FLOAT | Frequency
 | Ampl | I | FLOAT | Amplitude
 | Out | O | FLOAT | Signal
Comments: | The quality of the signal is dependent of: - the minimal cycle time of the target system - the adjusted cycle time and - the adjusted frequency (see also signal qualities).


Triangle signal

Symbol:

Description: | This function block generates a triangle wave signal with the specified frequency (Hz) and amplitude.

Signals: | Name | I/O | Type(s) | Function
 | Freq | I | FLOAT | Frequency
 | Ampl | I | FLOAT | Amplitude
 | Out | O | FLOAT | Signal
Comments: | The quality of the signal is dependent of: - the minimal cycle time of the target system - the adjusted cycle time and - the adjusted frequency (see also signal qualities).


Signal qualities

The quality of the signal is determined by the numbers of sampling points, which means the number of calculation cycles. The minimal cycle time of a task (program) is predefined by the minimal cycle time of the target system.

So the interrelationships can be described as follows:

The influence of the sample rate can be illustrated by the following two figures of a sine wave signal:

- frequency = 2Hz

- cycle time = 5ms

- number of sampling points per oscillation = 100

- frequency = 2Hz

- cycle time = 200ms

- number of sampling points per oscillation = 2