Clock generator

Symbol:

Description: | This function block generates a clock signal with a period T' given by the value of the input Takt, expressed in seconds. The given period must be two times larger than program block cycle. The clock generated by this function block will effectively have a period which is a multiple of the program block cycle time.

Signals: | Name | I/O | Type(s) | Function
 | Takt | I | FLOAT | Cycle period in [s]
 | Q | O | BIT | Pulse signal
Comment: | The output Q will stay at a logical 1 for one program block cycle. This time is part of the complete period T' (see figure).


Off- delay

Timer (Float)

Off-delay

Symbol:

Description:

This function block delays the negative-going edge of its input signal by a time given by Tv in seconds.

The output Q will change to a logic 0 after a time Tv from a negative transition on P. The real delay time is the value of Tv rounded up to the next cycle; in practice this means that only delay times which are multiples of the cycle time can be realized. Tv is given as a float value, expressed in seconds. Tv may have a value smaller than one second, but may not be negative.

A free-running counter with 1ms cycle time will be used as reference value. Any impulse shorter than the delay time will be ignored.

Signals: | Name | I/O | Type(s) | Function
 | P | I | BIT | Input signal
 | Tv | I | FLOAT | Delay time value in [s]
 | Q | O | BIT | Output signal
Visualization: | If the output Q is logical 1, the function block will be highlighted. (Only during online monitoring mode).
Comment: | If P stays at logic 0 for a time less than Tv, the output state will not change and the delay will be applied to the last edge (see I1 and I2 in the figure).


On-delay

Symbol:

Description:

This function block delays the positive-going edge of its input signal by a time given by Tv.

The output Q will change to a logical 1 after a time Tv in seconds from a positive transition on P. The real delay time is the value of Tv rounded up to the next cycle; in practice this means that only delay times which are multiples of the cycle time can be realized. Tv is given as a float value, expressed in seconds. Tv may have a value smaller than one second, but not negative.

A free-running counter with 1ms cycle time will be used as reference value. Any impulse shorter than the delay time will be ignored.

Signals: | Name | I/O | Type(s) | Function
 | P | I | BIT | Input signal
 | Tv | I | FLOAT | Delay time value in [s]
 | Q | O | BIT | Output signal
Visualization: | If the output Q is logical 1, the function block will be highlighted. (Only during online monitoring mode).
Comment: | If P stays positive for a time less than Tv, the output state will not change (see I2 in the figure).


Sawtooth generator

Symbol:

Description: | This function block generates a sawtooth signal with a period of b in [s] and an amplitude h*π. The period b should be appreciably higher than the program cycle time

Signals: | Name | I/O | Type(s) | Function
 | h | I | FLOAT | Amplitude
 | b | I | FLOAT | Period in [s]
 | Y | O | FLOAT | Output signal
Comment: | The block is typically used to generate a test signal, e.g. in conjunction with a sine function block.