PID-Controller (Percent)

Symbol: |
Description: | This function block PID-Controller (Percent) contains the following elements: - proportional term - integral term - differential term - integral wind-up avoidance logic - setup of controller output; with auto/manual selection The controller can be tuned with the multipliers (Kr, Ki, Kd). The error input d (d=W-X) is set internally by the controller. It is limited within the range of -100 to 100. The controller output is limited within the range of 0 to 100.
Operations: |
Signals: | Name |  | I/O | Type(s) |  | Function
 | W |  | I | FLOAT |  | Set point
 | X |  | I | FLOAT |  | Controlled variable (sensor input)
 | Kr |  | I | FLOAT |  | Proportional gain input
 | Ki |  | I | FLOAT |  | Integral multiplier
 | Kd |  | I | FLOAT |  | Differential multiplier
 | Yh |  | I | FLOAT |  | Manual set input
 | H |  | I | BIT |  | Manual mode
 | Slu |  | O | BIT |  | Deviation limit reached -100
 | Slo |  | O | BIT |  | Deviation limit reached 100
 | SYu |  | O | BIT |  | Control limit reached (output is 0)
 | SYo |  | O | BIT |  | Control limit reached (output is 100)
 | Y |  | O | FLOAT |  | Controller output
Parameter-ization: | Ki | = 0 |  |  | I-term is off
 | Kd | = 0 |  |  | D-term is off
 | H | = 1 |  |  | Manual mode - Yh is channeled directly to Y
Visualization: | The symbol indicates, whether the controller runs in automatic or in manual mode.


PID-Controller (Universal)

Symbol

(samples):

[A]

[B]

Without limit controller output

[B]

Disturbance feed forward

and with limit inputs

[C]

Disturbance feed forward

[D]

Description:

This function block PID-Controller (Universal) contains the following elements:

- proportional term

- integral term

- differential term

- integral wind-up avoidance logic

- setup of controller output; with auto/manual selection

The function block supports four types of PID-controllers. Depending in the selection, there are different input and output connectors available.

Type 1 [a] | Shared error input for P-, I- and D-term
Type 2 [b] | Individual error input for P-, I- and D-term
Type 3 [c] | Setpoint and controlled variable as input, the error input d (d=W-X) is set in the controller
Type 4 [d] | Setpoint and controlled variable as input, the error input d (d=W-X) for the P- and I-term is set in the controller, for the D-term it is calculated from the change of the controlled variable.

The input pins must be connected. The controller can be tuned by the multiplier (Kr) and by the multipliers (Ki, Kd) or by the time constants (Tn, Tv). The controller subtracts the disturbance (Z) from the controller output before it is limited.

Limit pins and factors pins must be connected if they are visible.

"Manual" mode: (H) – dominant

- The controller works with a manual differential signal input (Yh).

"Disturbance" mode: (PS)

- The controller works with the disturbance signal input (Z).

The controller output is limited by the limit controller output. The limit indicator bits (SYu and SYo) are set, if a limit is reached.

Parameter:

The parameter dialog can be used to select the type of the PID-controller and several variations within each type. The available input and output connectors can be selected and the interpretation of the input parameters (time based or coefficient). Additionally the terms which have an effect in the controlling (PID, PI, PD) can be defined.

Operations:

Legend:

T Cycle time

Signals:

Name

I/O

Type(s)

Function

d

I

FLOAT

Error input [a]

dP

I

FLOAT

Error input; P-term [b]

dI

I

FLOAT

Error input; I-term [b]

dD

I

FLOAT

Error input; D-term [b]

W

I

FLOAT

Setpoint [c], [d]

X

I

FLOAT

Controlled variable (sensor input) [c], [d]

Z

I

FLOAT

Disturbance (disturbance feed forward)

lu

I

FLOAT

Lower limit inputs

lo

I

FLOAT

Upper limit inputs

Kr

I

FLOAT

Proportional multiplier

Ki, Tn

I

FLOAT

Integral multiplier, term integral time constant in [s]

Kd, Tv

I

FLOAT

Differential multiplier, term differential time constant in [s]

Yh

I

FLOAT

Manual set input

H

I

BIT

Manual mode

PS

I

BIT

Disturbance mode, Preset (disturbance feed forward)

Yu

I

FLOAT

Lower limit controller output, wind-up

Yo

I

FLOAT

Upper limit controller output, wind-up

Slu

O

BIT

Lower limit (error W-X) reached

Slo

O

BIT

Upper limit (error W-X) reached

SYu

O

BIT

Lower controller output limit (Yu) reached

SYo

O

BIT

Upper controller output limit (Yu) reached

Y

O

FLOAT

Controller output

dY

O

FLOAT

Controller output (y[n] - y[n-1])

Parameter-ization:

Ki

= 0

I-term is off

Tn

= 0

I-term is off

Kd

= 0

D-term is off

Tv

= 0

D-term is off

H

= 1

Manual mode - Yh is channeled directly to Y (dominant)

PS

= 1

Disturbance mode – The signal Z is channeled directly to Y

Examples:

Controlled system: PT1-term (T1=4)

Ki=0,5 Kd=1,0

Step response, change proportional multiplier

Kr=0,5 Kd=1,0

Step response, change integral multiplier

Kr=0,5 Ki=0,7

Step response, change differential multiplier

Visualization:

The symbol indicates, whether the controller runs in automatic or in manual mode.